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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also emphasizes lines of code 
that are different from the other examples.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.
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1
Introduction to Calibration 
Executive

This manual describes how to install and use National Instruments 
Calibration Executive (version 2.1 and later) to calibrate hardware devices. 

Related Documentation
Each device that Calibration Executive supports has its own calibration 
procedure document in PDF format. The default installation directory is 
C:\Program Files\National Instruments\Calibration 
Executive\Documentation.

Overview of Calibration Executive
Calibration Executive, developed primarily for metrology labs, provides 
an integrated software environment in which to verify and adjust 
NI measurement devices.

Features
Calibration Executive has the following capabilities:

• Externally calibrates many NI measurement devices 

• Operates in automatic or manual mode through an intuitive user 
interface

• Configures and controls calibration instruments automatically

• Stores calibration reports in a central database

• Expands as new hardware calibration procedures are added
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Engine and Modules
The Calibration Executive engine provides the core calibration, control, 
and reporting functionality. Each individual calibration procedure provides 
the calibration routines and automation for a specific measurement device 
family. With this modular architecture, you can easily add more calibration 
procedure modules as they are developed.

For a current list of supported products and required calibration hardware, 
visit ni.com/calibration.

Minimum System Requirements
For proper operation of the Calibration Executive software, your computer 
must meet the following requirements:

• Pentium 266 MHz processor or higher

• 64 MB of RAM

• VGA monitor capable of 800 × 600 resolution, 256 colors

• Windows 2000/NT/XP (Windows NT 4.0 requires Service Pack 6)

Note Calibration Executive is not compatible with operating systems that use wide 
characters (for example, Japanese or Chinese).

Calibration Executive only supports using periods (.) for decimal places. 
If your computer is configured to use commas as decimal places, change 
the settings on the Numbers tab as follows:

1. Select Start»Settings»Control Panel.

2. Click Regional Options.

3. Click the Numbers tab and change the Decimal Symbol from a 
comma to a period. Change the Digit Grouping Symbol from a comma 
to a period.

Note If you change the Regional Settings or Regional Options on the computer, you may 
want to change them back to the default settings after running the Calibration Executive 
procedure.



Chapter 1 Introduction to Calibration Executive

© National Instruments Corporation 1-3 Calibration Executive Software User Manual

Installing Calibration Executive

Notes The Calibration Executive 2.1 (or later) installer deletes any users that you 
configured in Calibration Executive 2.0. You must recreate those user accounts after 
installation. 

If you are running Windows 2000/NT/XP, you must log in with administrator privileges.

Before installing Calibration Executive, exit any virus detection software. In particular, 
ensure that the McAfee vsstat.exe file is not running from the Windows Task Manager. 
vsstat.exe may cause part of the Calibration Executive installer to hang. 

Caution National Instruments recommends uninstalling Calibration Executive 2.0 and the 
associated calibration procedures before installing Calibration Executive 2.1 (or later). 
The Calibration Executive 2.0 uninstaller removes the Calibration Executive\
Databases\Calibration Reports.mdb file, which is the database file where 
calibration reports are stored. To prevent the loss of your stored calibration data, back 
up this file before uninstalling Calibration Executive 2.0. After uninstalling, restore the 
Calibration Reports.mdb.

To install Calibration Executive and all available calibration procedures, 
complete the following steps:

1. Close all open applications on your computer.

2. Insert the Calibration Executive installation CD into the CD drive. 
The installer program starts automatically.

3. Follow the instructions that appear in the dialog boxes.

If the installer program does not start automatically, complete the following 
steps:

1. Select Start»Run.

2. In the command line box, enter x:\setup.exe (where x is the letter 
of the CD drive you are using).

3. Click OK.

4. Follow the instructions that appear in the dialog boxes.
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What the Setup Program Installs
The setup program installs Calibration Executive and the associated files 
listed in Table 1-1.

Note By default, the setup program installs NI-VISA and IVI drivers in the c:\Vxipnp 
directory.

Loading and Running Calibration Procedures

Note Before you begin using Calibration Executive, thoroughly read the Readme.html 
file that is installed with Calibration Executive. This file contains important information on 
installation and compatibility issues. You can access Readme.html by going to 
Start»Programs»National Instruments»Calibration Executive»Documentation.

To load and run a calibration procedure, complete the following steps:

1. Launch Calibration Executive by selecting Start»Programs»
National Instruments»Calibration Executive.

2. In the Login dialog box, select administrator by clicking the User 
Name control and selecting it from the drop-down list. 

3. Click OK without entering a password. You can create, edit, and 
delete user names and passwords in Calibration Executive. For more 
information, refer to the Configure Menu section of Chapter 2, Using 
Calibration Executive.

4. Complete the steps in the Calibration Configuration Wizard. This 
wizard prompts you to supply the information needed to configure and 
load the calibration procedure for the device you are calibrating.

Table 1-1.  Calibration Executive Directories and Supporting Files

File Name Contents

Databases Microsoft Access databases that store the calibration reports.

Buttons Icon files that represent the buttons displayed on the user interface.

Procedures Directory structure that contains the available calibration procedures, 
including specification databases and any support drivers or DLLs required 
to run a specific procedure.

Templates HTML templates used to generate the calibration report.

TestStand TestStand run-time engine required to run calibration procedures.
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5. After completing the wizard, select Execute»Run Procedure from the 
menu bar, or click the Run Procedures button.

6. After the procedure finishes, select View»Reports.

7. Select View to view the calibration information in a printable HTML 
file or a text report.

Note For more information on loading and running specific procedures, refer to the 
individual procedure documents that are installed with the Calibration Executive software.

Uninstalling the Calibration Executive Software
Each of the installed software products supplied by NI has its own uninstall 
information. To remove any of these products from your system, use the 
Add/Remove Programs utility in your system control panel. Many of these 
programs update your Windows registry and place files in your system 
directory; manual deletion of these files is not recommended.
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2
Using Calibration Executive 

This chapter describes the main parts of the Calibration Executive user 
interface and explains how to use the Calibration Configuration Wizard, 
Cover Page Editor, calibration reports, and the calibration reports database.

Major Components of Calibration Executive
Calibration Executive is designed using National Instruments LabVIEW, 
CVI, IVI, TestStand, and NI-VISA. A core component of Calibration 
Executive is the calibration engine. This engine, which includes the user 
interface, communicates with the following drivers and databases to 
control the calibration process:

• Interchangeable Virtual Instruments (IVI)—A software standard 
for creating a common interface (API) to common test and 
measurement instruments. The IVI driver communicates with 
your standards during calibration, typically using GPIB.

• Report Database—A Microsoft Access database that stores the 
calibration results about assets you have calibrated, such as 
verification readings taken before and after calibration.

• TestStand—A test executive framework that manages the calibration 
procedures used to calibrate the asset.
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The calibration engine also creates calibration reports. Figure 2-1 shows 
the calibration engine and its major components.

Figure 2-1.  Calibration Engine

Automated Versus Manual Calibration
Calibration Executive calibrates devices in either automatic or manual 
mode. If the IVI driver supports the calibration standard(s) you are using 
and you have a GPIB card, Calibration Executive automates verification 
and adjustment by communicating directly with the calibration standards. 
If you do not have IVI-supported standard(s), you must run the procedure 
in manual mode. In manual mode, Calibration Executive prompts you to 
manually control the standard(s). Calibration Executive then makes the 
necessary verification and/or adjustment to the asset.

Calibration Information
(Asset, Customer, Environment)

Calibration Report

Calibration EngineIVI Report Database

TestStand
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Calibration Executive User Interface
Figure 2-2 shows the main Calibration Executive user interface, the 
procedure status window and its main components.

Figure 2-2.  Procedure Status Window

Menu Bar
The menu bar contains the following menus: File, Execute, View, 
Configure, and Help, which are described in the following sections.

File Menu
Using the File menu, you can log in as a new user, log out, open a new 
procedure, or exit from Calibration Executive.

1 Menu Bar
2 Toolbar

3 Step Display Headers
4 Names of Steps

1

2

3

4
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Login
File»Login prompts you for a login name and password. This option is 
visible on the File menu only after you log out the current user. You can 
then use the Login option to log in as a different user. Each user can have 
different privileges, so logging in as a different user can change your 
privileges. For more information on user privileges, refer to the User 
section. 

Note When you first launch Calibration Executive, a login dialog box appears 
automatically—you cannot use the File menu for login if another user is already logged in.

Logout
File»Logout logs out the current user and enables the Login selection 
under the File menu.

Open Procedure
File»Open Procedure loads and configures a calibration procedure. 
For more information, refer to the Calibration Configuration Wizard 
section.

Exit
File»Exit closes Calibration Executive. If a calibration procedure is 
currently loaded, the procedure unloads before the calibration engine 
closes.

Execute Menu
Using the Execute menu, you can run a procedure, stop a procedure, 
and select the run mode.

Run Procedure
Execute»Run Procedure executes the currently loaded procedure. 

Stop Procedure
Execute»Stop Procedure ends a running procedure. You can stop the 
execution of a calibration procedure at any time. When you stop a 
procedure, Calibration Executive writes any data collected during 
the calibration to the calibration reports database.



Chapter 2 Using Calibration Executive

© National Instruments Corporation 2-5 Calibration Executive Software User Manual

Note You cannot restart a calibration procedure in the same position in which you stopped 
the procedure. You can, however, restart the procedure from the beginning by selecting 
Execute»Run Procedure. All of the settings configured in the Calibration Configuration 
Wizard remain the same.

Run Mode
Execute»Run Mode allows you to select from the following options:

• Verify Only

• Verify, Adjust Failed, Reverify Failed

• Verify, Adjust All, Reverify All

• Adjust Only

Note Not all calibration procedures support all of the run modes. If a run mode is not 
available in a procedure, the run mode entry will be disabled in the menu.

The default mode is Verify, Adjust All, Reverify All, in which the 
calibration procedure verifies the measurements of the asset, adjusts its 
measurement capability, and reverifies the measurements after adjustment. 
If you do not want to adjust the measurement capability of the asset but 
need to know how accurately it is measuring, select Verify Only.

View Menu
Using the View menu, you can view calibration reports and configuration 
information.

Reports
View»Reports opens the report viewer window. Use the report viewer 
window to select and view a stored calibration report. For more information 
on viewing, printing, and deleting a calibration report, refer to the 
Calibration Reports section.

Configuration
View»Configuration launches the Current Procedure Configuration 
dialog box, which displays all the information about assets, standards, 
environment, and users that you entered in the Calibration Configuration 
Wizard. To modify this information, you must launch the wizard by 
opening a procedure.
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Configure Menu
Using the Configure menu, you can change user information, select 
applications to display calibration reports, select file locations for reports, 
and customize report generation.

Report Options
Configure»Report Options configures how Calibration Executive 
displays reports at the end of running a procedure. The choices are as 
follows:

• HTML report, the default report option, shows the calibration report as 
an HTML file in your configured browser. 

• HTML Report with Cover Page creates an HTML cover page in 
addition to the HTML report. Click Customize Cover Page to launch 
the Cover Page Editor, which guides you through creating a custom 
cover page. 

• Tab-delimited text report shows your report as a tab-delimited text file, 
which you can display as a text file or in a spreadsheet application such 
as Microsoft Excel. 

Database Options
Configure»Database Options configures the database that stores 
calibration reports. The Database Options dialog box, shown in Figure 2-3, 
contains the Database Path information. Database Path is the complete path 
to the Microsoft Access database that stores the calibration reports.

Figure 2-3.  Database Options Dialog Box

Any changes you make to file locations do not take effect until you restart 
Calibration Executive.
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Station Options
Configure»Station Options»Launch configuration wizard on startup 
launches the Calibration Configuration Wizard automatically when you 
open Calibration Executive. If this option is not selected, you must select 
File»Open Procedure to launch the wizard or click Open Procedure on 
the toolbar.

User
Configure»User displays the dialog box shown in Figure 2-4, in which 
you can add users, delete users, and edit user privileges.

Figure 2-4.  User Configuration Dialog Box

To add a new user, complete the following steps:

1. Click Add to display the New User dialog box.

2. Specify a case-sensitive login name and password in the User Name 
and Password controls, as shown in Figure 2-5.
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Figure 2-5.  Add New User Dialog Box

Note The Full Name and Comment fields are optional. 

3. Select a profile in the User Profile ring control to define an initial set 
of privileges for new users. Calibration Executive offers different 
features to users depending on their login privileges. Refer to Table 2-1 
for specific user privileges.

 

4. Click OK to save your changes and close the dialog box.

To delete a user name, complete the following steps:

1. Highlight the name of the user you want to remove.

2. Click Delete.

3. Click OK to save your changes and close the dialog box.

Table 2-1.  User Privileges

Feature
Non-Administrator 

Privilege
Administrator 

Privilege

Create/edit/delete users No Yes

Configure file locations No Yes

Delete calibration reports No Yes
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Note You cannot delete your own login information.

To modify the login name, comments, or password associated with the 
selected user, complete the following steps:

1. Click Edit to open the Edit User dialog box, shown in Figure 2-6.

Figure 2-6.  Edit User Dialog Box

2. Modify the information you want to change.

3. Click OK to save your changes and close the Edit User dialog box.

Note Clicking the Advanced button displays the Edit Flags dialog box, which contains 
TestStand property flags you can modify. You need to configure these property flags only 
when you are developing a relatively sophisticated custom type in TestStand. The 
Advanced button has no function in Calibration Executive. 

Toolbar
The toolbar contains the following shortcuts to commonly used selections 
of the menu bar:

• Open Procedure

• View Calibration Reports

• Run Procedure

• Stop Procedure Execution
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Procedure Status Window
The step information columns in the user interface display the following 
information about the calibration procedure:

• Step Name displays which values are being verified or adjusted.

• Step Comments provides feedback on individual steps while a 
calibration procedure is running.

• Step Status indicates whether a step passed or failed.

Status Bar
The status bar, located at the bottom of the user interface, displays the 
following information about the calibration procedure:

• Procedure displays the name of the currently loaded procedure. 
If no procedure is loaded, none is displayed.

• Percent Complete displays the percentage of a given procedure step 
that is complete.

• User displays the login name of the current user. If no user is logged 
in, none is displayed.

Calibration Configuration Wizard
The Calibration Configuration Wizard configures and loads calibration 
procedures for you. This wizard gathers the customer information, asset 
information, available standards, and calibration conditions necessary to 
calibrate your asset. When you complete the wizard, your asset is ready 
to calibrate. To see the data that the wizard has gathered, go to 
View»Configuration. The calibration report and the calibration reports 
database also contain this configuration data.

The Calibration Configuration Wizard launches automatically when you 
open Calibration Executive unless you deselect this option in the Configure 
menu at Configure»Station Options»Launch configuration wizard on 
startup. 

To guarantee conformity between calibrations, you must enter data in all of 
the fields not marked as optional. If the required data is not entered, you 
cannot continue to the next configuration dialog box.
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Customer Information
In the Customer Information dialog box, shown in Figure 2-7, enter the 
customer name, address, and purchase order. You must fill in all these 
fields before proceeding. If you do not have a purchase order number, 
enter N/A.

Note If you do not enter something in all of the required fields, you cannot continue to the 
next step in the Calibration Configuration Wizard.

If you have any additional notes, you can enter them in the Notes field.

Figure 2-7.  Customer Information
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Asset Information
In the Asset Information dialog box, shown in Figure 2-8, select the asset 
you want to calibrate from the displayed list, and enter the tracking number 
and serial number for the asset. A tracking number is a number that certain 
organizations assign to their equipment that keeps track of the user, the 
location, and the calibration data of the equipment. If the asset does not 
have a tracking number, enter N/A in the Tracking Number field.

Figure 2-8.  Asset Information 
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Standard Information
A dialog box displays a list of standards you need for the calibration 
procedure you have selected, as shown in Figure 2-9.

Figure 2-9.  Required Standards Information

You can select and configure the standards required to calibrate an asset. 
Each standard (for example, the calibrator, the DMM, or the counter/timer 
device) has its own information dialog box. When you complete the 
information for the first standard, click Next, and complete the information 
for the next standard.

The Standard list displays all of the standards that Calibration Executive 
supports—for example, calibrators and DMMs. If you are using a standard 
that is displayed in the list, select it by highlighting the name of the 
standard. If you are using a standard that is not listed, you can still calibrate 
the asset in manual mode. In manual mode, Calibration Executive prompts 
you to enter values on your standard when you run a calibration procedure. 
Calibration Executive then verifies or adjusts the measurement. 
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Figure 2-10.  Supported Standards

The Available Addresses list displays all of the GPIB instruments that 
are connected to your computer. If the address of your instrument is not 
displayed in the list, ensure that the instrument is connected, and click 
Refresh.

Note To run a calibration procedure in automated mode, you must select the standard and 
its associated GPIB address.
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If you do not have one of the supported standards or if the standard is not 
connected through GPIB, select the following items:

• In the Standard window, select No driver available. This will use 
manual mode.

• In the Address window, select none.

Note In manual mode, the procedure prompts you to manually control your standards. 

Calibration Conditions
In the Calibration Conditions dialog box, shown in Figure 2-11, 
enter temperature and humidity information as numerals or characters 
(for example, 28 C). Temperature can be in Celsius or Fahrenheit.

Figure 2-11.  Calibration Conditions

Click Finish to complete the Calibration Configuration Wizard and return 
to the Procedure Status window.

Calibration Reports
The calibration reports are stored in a central database. Calibration 
Executive retrieves the data from this database and displays the report in 
the configured viewer. Each report includes the customer name, purchase 
order number, calibration date, and asset type for all assets that have been 
calibrated.
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Viewing a Calibration Report
You can view calibration reports in one of three formats: HTML, 
HTML with a cover page, or tab-delimited text.

To configure the report format and view the report, complete the following 
steps:

1. Select View»Reports.

2. Select Text or HTML. If you select HTML, select the HTML report 
type also.

3. In the Calibration Reports dialog box, highlight a calibration report 
from the displayed list.

4. Click View to view the calibration report, or double-click the name of 
a report in the list.

5. Click Close when you have finished viewing the report.

Note If you choose to view an HTML report with a cover page and your browser is already 
open, you may see only the cover page without the report. To view both the cover page and 
the report, deselect all of your Web browser windows and click View in the Calibration 
Reports dialog box.

When you view a report, Calibration Executive retrieves the calibration 
data from the reports database, formats the data into an HTML or 
tab-delimited text file, and launches your viewer to display the file. If you 
need a printout of the calibration report, use the print functions for your 
browser or other external viewer.

To remove the highlighted calibration report, click Delete. Deleted reports 
are permanently removed from the database and cannot be recovered. 
You can delete reports only if you log in with Administrator privileges. 
For more information on user privileges, refer to the User section.

End of Procedure Report Options
You also can choose to view your report automatically at the end of a 
procedure by completing the following steps:

1. Select Configure»Report Options. 

2. Check the box labeled View the calibration report at the end of the 
procedure, as shown in Figure 2-12.
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Figure 2-12.  Report Options 

3. Select a format from the Report Mode listbox.

4. If you have selected HTML Report with Cover Page, click Customize 
Cover Page and follow the instructions in the Cover Page Editor 
section. If you have selected another report format, click OK.

Modifying the Font Size in a Calibration Report
If you have selected one of the HTML formats and the text size in the 
calibration report is too large, you can decrease the font size as follows:

• In Internet Explorer, modify the text size by selecting View»Text Size, 
then select the appropriate size from the menu.

• In Netscape, modify the text size by selecting View»Decrease Font.

Understanding the Calibration Report
Several terms are common to all of the calibration report tables. Low Limit 
is the lower limit of the reading allowable to meet specifications. Reading 
is the actual reading taken during the calibration procedure. High Limit is 
the upper limit allowable to meet specifications. For an ideal calibration, 
the reading value always lies between the upper and lower limits. If the 
reading is outside this range, the calibration fails and FAILED appears in the 
Pass/Fail column.

Also common to these tables are the As Found and As Left columns. The 
As Found column details the response of the asset prior to any adjustment, 
or as received at the calibration lab. Therefore, if the asset is out of 
calibration, the As Found tests can fail. The As Left column represents the 
asset performance after calibration, or as the asset left the calibration lab. 
The asset should pass the As Left tests.
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Cover Page Editor
This section describes the Cover Page Editor and explains how to design 
and create a cover page template. The Cover Page Editor is a drag-and-drop 
editor that allows you to design and customize your calibration report cover 
page. A calibration report cover page can consist of up to 20 each of the 
following fields: 

• Graphics

• Full-width text

• Resizable text

• A table listing the standards used during calibration

• Properties that are part of the calibration procedure

When you use the Cover Page Editor, you create an HTML template file. 
When you finish designing the cover page, you can preview it using your 
HTML browser and/or you can save the template. 

Launching the Cover Page Editor
To launch the Cover Page Editor, complete the following steps:

1. Select View»Reports from the main menu. The Calibration Reports 
dialog box appears, as shown in Figure 2-13.

Figure 2-13.  Calibration Reports Dialog Box



Chapter 2 Using Calibration Executive

© National Instruments Corporation 2-19 Calibration Executive Software User Manual

a. Select HTML Report.

b. In the HTML Report Type control, select Report with Cover 
Page.

2. Click Customize Cover Page. The Cover Page Editor displays a blank 
template, as shown in Figure 2-14.

Figure 2-14.  The Cover Page Editor Template

Tip Instead of starting a new cover page from scratch, you can click Load Template to 
display the saved template. You can then modify the existing template as needed.

Creating a Customized Cover Page
Using the controls in the left side of the template, you can do the following:

• Add Fields—To add a field to your cover page, select the field on the 
left side of the template. When you click the field, the cursor changes 
to a four-point arrow. Drag the field to the right side of the template and 
click to drop it where you want it. You can drag and drop each of the 
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fields up to 20 times. However, you can only add one field at a time. To 
add Property fields, select one property at a time from the drop-down 
list and drag to the template.

• Move Fields—To move a field to a different location on the template, 
select the Position editing mode, as shown in Figure 2-15, then drag 
and drop the field in the new location.

Figure 2-15.  Position Mode

• Edit Contents—To modify the contents of a field, select the Edit 
Contents mode, as shown in Figure 2-16, then highlight the contents 
of the field and enter the new information. 

Figure 2-16.  Edit Contents Mode

• Delete Fields—To remove a field from the template, click the field and 
press <Shift-Delete>.

• Resize Fields—To resize a field, click the field and use the resize 
buttons, shown in Figure 2-17. You can return a field to its original size 
by clicking Restore Default Size.

Figure 2-17.  Resize Buttons

Note At any time, you can switch between the two editing modes, Position and Edit, 
to arrange or customize the fields as needed.
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• Preview Cover Page—To preview the cover page in your Web 
browser, click Preview. Calibration Executive launches the current 
configuration in the default browser, providing a Web preview of the 
cover page.

• Load Template—To use a previously saved template, click Load 
Template. You can modify this template as needed for your new cover 
page.

• Save Template—To save the template you are currently configuring, 
click Save Template. This action also closes the editor.

Field Types and Capabilities
Table 2-2 lists each of the field types available in the Cover Page Editor and 
what you can do with each type. 

Table 2-2.  Cover Page Fields

Field Type Editing Capability

Graphic Browse for graphic files. The Cover Page Editor 
supports JPEG and GIF files. The Cover Page Editor 
stores an absolute path to the graphic file.

Full Width Text—Occupies the full width 
of the HTML page

Modify the text.

Resizable Text—Small strings, for 
example, Seal, Calibration Engineer, 
and so on

Modify the text.

Standards—Table listing the calibration 
standards used. Occupies the full width 
of the HTML page.

Include the standards table in the cover page template.
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Calibration Reports Database
The calibration reports database, a Microsoft Access database, contains all 
of the results for each calibration. By default, the database is named 
Calibration Reports.mdb and is stored in the Databases folder of 
Calibration Executive. If you installed Calibration Executive in the default 
location, this database is located in x:/Program Files/National 
Instruments/Calibration Executive/Databases, where x is the 
drive in which Calibration Executive is installed.

The calibration reports database responds to standard structured query 
language (SQL) commands. Therefore, you can write your own 
report-handling routine to retrieve data from the database. You could write 
such a routine in LabVIEW, C, Visual Basic, or any other language that 
supports SQL communication.

The calibration reports database consists of the following seven tables:

• ASSET contains all of the information about the calibrated asset.

• CALIBRATION_DATA contains all the data acquired during the 
calibration, as well as the uncertainty data, if applicable.

Property

(Properties can be displayed in the form 
of a table.) 

You can change the label for the property by editing the 
text box. Select from any of the following properties: 

• Manufacturer

• Asset/DUT Type

• Model/Asset

• Serial Number

• Tracking Number

• Asset/DUT Notes

• Customer

• Customer Address

• Purchase Order

• Customer Notes

• Temperature

• Humidity

• Calibration Date

• Calibration Due Date

• Technician

The information for many of these properties comes 
from the Calibration Configuration Wizard or from the 
calibration procedure. 

Table 2-2.  Cover Page Fields (Continued)

Field Type Editing Capability
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• CUSTOMER contains all of the customer information associated 
with the asset.

• ENGINE contains information about the operator and the 
calibration date.

• ENVIRONMENT contains information about the environmental 
conditions during the calibration.

• STANDARD contains information about the standards, such as 
calibrators and DMMs, that were used during the calibration.

• REPORT keeps track of all of the relationships between the six 
other tables.

The REPORT table contains a search value for each of the other tables. 
The search value is a unique number that represents all of the data 
associated with a specific calibration report—all the customer information, 
calibration condition information, and so on. To locate data associated with 
a given calibration, you must first find the search value for that data in the 
REPORT table. When you know the search value number for a specific 
report, you can search for a match to that number in the other search value 
fields of the table.

Example: Using the Calibration Reports Database
Suppose you want to find out all the calibration-related information—the 
calibration conditions, asset specifics, calibration data, and so on—about 
the assets you have calibrated for a customer. To find that information, start 
by opening the CUSTOMER table and locating the name of your client. 
In the same row that the customer name appears, there is a numeric search 
value. With that search value, you can open the REPORT table and use that 
value to search the other tables for that customer’s asset information, 
calibration data, and so on. You could also use that search value to write 
your own asset-handling routine.

Specifications
To find the specifications of the device you are calibrating, select one of the 
following methods:

• Visit ni.com/calibration to find the manual calibration procedure 
for the device.

• Visit ni.com/products to find the data sheet for the device.

• Refer to the hardware documentation for the device.
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3
Measurement Uncertainty

This chapter describes how Calibration Executive handles measurement 
uncertainty. To determine if a particular procedure supports automatic 
uncertainty calculations, refer to the calibration procedure documentation 
for the device you are calibrating. For procedures that do not include 
automatic uncertainty calculations, you can calculate the uncertainty 
manually.

What Is Measurement Uncertainty?
Measurement uncertainty is defined by NCSL RP3-1988 as an estimate of 
the range of values about the measured value in which the accepted value 
is believed to lie. A total uncertainty value represents the combination of a 
measure of the random error and estimated bounds of the systematic error, 
and considers all factors that contribute to the measurement uncertainty. 
For detailed information about measurement uncertainty, refer to 
ANSI/NCSL Z540-2-1997, U.S. Guide to the Expression of Uncertainty in 
Measurement.

For some devices, Calibration Executive can calculate measurement 
uncertainties for you. When you run the procedure, the software prompts 
you to select whether to perform measurement uncertainty calculations. 
If you select No, the procedure runs without calculating uncertainty. If you 
select Yes, the procedure prompts you for which uncertainty file you want 
to use.

How Does Calibration Executive Calculate Measurement Uncertainty?
When calculating measurement uncertainty, Calibration Executive 
accounts for Type A uncertainty and Type B uncertainty. Table 3-1 
explains the calculations for these uncertainty components.

Note Type B uncertainty consists of two parts: uncertainty of the reference standard and 
resolution uncertainty of the UUT.
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After the standard uncertainty components are calculated, they are 
combined using the square root of the sum of the squares method to arrive 
at the combined standard uncertainty. The expanded uncertainty of 
measurement that Calibration Executive prints on the calibration report 
is this combined standard uncertainty of measurement multiplied by the 
coverage factor k = 1.96, which for a normal distribution corresponds to 
a coverage probability of approximately 95%.

Table 3-1.  Uncertainty Components

Component Description

Type A uncertainty Defined as the standard deviation of the measurements 
divided by the square root of the number of measurements. 
This calculation is based on different numbers of 
measurements for different products. Degrees of freedom is 
taken into account in cases where the number of degrees of 
freedom is not considered infinite.

Type B uncertainty, part 1: 
uncertainty of the reference standard

where N is the number of measurements taken and f 
accounts for the t-distribution. Including the t-distribution 
is only necessary in cases where the number of degrees of 
freedom is not considered infinite.

Type B uncertainty, part 2: 
resolution uncertainty of the device

where Resolution of the Device is the accuracy of the 
smallest meaningful displayed digit normalized using 
a rectangular distribution. The  term comes from 
assuming a rectangular distribution of probabilities of 
the values of measurements.

Standard Deviation of Measurements Taken
N

---------------------------------------------------------------------------------------------------------- f×=

1
2
--- Resolution ofthe Device

3
---------------------------------------------------------- 
 =

3
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Example: Calculating the Uncertainty for a Test Point
The following example is the uncertainty calculation for the 
PCI-MIO-16XE-10 at the 9.98 V analog input test point, 20 V range, 
bipolar mode (±10 V), using a Fluke 5720A calibrator that was calibrated 
one year ago.

• Calibrator uncertainty—the specification for the Fluke 5720A 
calibrator at 1 year, 95% confidence level (k = 1.96 for normal 
distribution) is 3.5 ppm + 2.5 µV. 

3.5 ppm × 9.98 V + 2.5 µV = 37.43 µV

Standard Uncertainty = (37.43 µV)/1.96 = 19.1 µV

• Resolution of device:

Resolution = Range/Number of Levels of 16-bit ADC

= 20 V/216

= 305.175 µV

• Noise and other Type A uncertainty—standard deviation from 
10,000 measurements was 207 µV.

= 2.07 µV

• Combined standard uncertainty—use the square root of sum of squares 
method:

Combined Standard Uncertainty

= 90.2 µV (1 sigma normal distribution)

Standard Uncertainty 1
2
--- Resolution

3
------------------------- 
  88.1 µV==

Standard Uncertainty of Mean Standard Deviation
N

-----------------------------------------------=

207 µV
10,000

--------------------=

19.1 µV2 88.1 µV2 2.07 µV2+ +=
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• Final expanded uncertainty—To convert into 95% confidence level, 
multiply the standard uncertainty by the coverage factor.

90.2 µV × 1.96 = ±177 µV

±177 µV is the value printed on the calibration report.

Uncertainty Files for Standards
Calibration Executive stores uncertainty information for common 
standards, including calibrators and DMMs, in tab-delimited text files 
under the Calibration Executive\Uncertainty directory. 
Calibration Executive prompts you to select whether to include uncertainty 
information when you run a procedure.

The Calibrator Uncertainty Information dialog box, shown in Figure 3-1, 
displays the list of calibrators for which Calibration Executive has 
uncertainty files. You can select a calibrator from the displayed list, or you 
can browse to select another uncertainty file.

Figure 3-1.  Calibrator Uncertainty Information

The DMM Uncertainty Information dialog box, shown in Figure 3-2, 
displays the list of DMMs for which Calibration Executive has uncertainty 
files. You can select the DMM model you are using from the displayed list, 
or you can browse to select another uncertainty file.



Chapter 3 Measurement Uncertainty

© National Instruments Corporation 3-5 Calibration Executive Software User Manual

Figure 3-2.  DMM Uncertainty Information

Each uncertainty file contains a confidence level that corresponds to a 
coverage factor, as listed in Table 3-2. These coverage factors assume 
an infinite number of degrees of freedom.

Note For a more detailed table of confidence levels and coverage factors, refer to Annex G 
in ANSI/NCSL Z540-2-1997, U.S. Guide to the Expression of Uncertainty in 
Measurement.

Uncertainty Files for Commonly-Used Standards
The information in the uncertainty files is taken from the manufacturer’s 
specifications for each particular instrument, at a confidence level shown 
in the specifications and at the top of the uncertainty file.

Note Uncertainty files contain specifications expressed in specific units. For example, 
calibrator uncertainty files generally contain ppm output and µV offset, whereas DMM 
uncertainty files generally contain ppm reading and ppm range. If the specifications for 
your instrument are not in this format, you must convert them to the same units. 

Table 3-2.  Confidence Levels and Corresponding Coverage Factors

90% 95% 95.45% 99% 99.73%

1.645 1.960 2.000 2.576 3.000
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For example, if the specifications of your calibrator are given in percent output and mV 
offset, you must convert them correctly to ppm output and µV offset, respectively. If the 
confidence level is not given in the instrument specifications, you can assume a 95% 
confidence level and set the coverage factor to 1.96. For more information, refer to 
Annex G in ANSI/NCSL Z540-2-1997, U.S. Guide to the Expression of Uncertainty in 
Measurement.

Template Files
If you use instruments that do not have uncertainty files provided by 
Calibration Executive, you can create your own uncertainty files by using 
the template files. Template files named Calibrator Template.txt 
and DMM Template.txt are provided in their respective directories under 
Calibration Executive\Uncertainty.

Tip Instead of using the template files, you can modify an existing DMM or calibrator 
uncertainty file by making a copy of the file and changing the appropriate information for 
the standard you are using.

Uncertainty Calculations of Reference Standards
The uncertainty of the calibrator depends on what range it is operating in 
and what output value it is returning. Calibration Executive calculates the 
uncertainty of a DC voltage test point for a calibrator as follows:

1. Searches in the proper uncertainty file for the row in which the test 
value is less than the range.

2. Retrieves the ppm output and µV offset from that row.

3. Calculates uncertainty using the formula 

4. Calculates standard uncertainty using the formula

because a 95% confidence level corresponds to a coverage factor 
of 1.96.

The standard uncertainty is the value that Calibration Executive combines 
with the other standard uncertainties using the root-sum-square method to 
determine the combined standard uncertainty.

Uncertainty ppm Output Test Value×
1,000,000

------------------------------------------------------------ µV Offset
1,000,000
------------------------+=

Standard Uncertainty Uncertainty
1.96

----------------------------=
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The uncertainty of the DMM depends on what range it is operating in and 
the value that it is reading. Calibration Executive calculates the uncertainty 
of a DC voltage test point for a DMM as follows:

1. Searches in the proper uncertainty file for the row in which the test 
value is less than the Range.

2. Retrieves the Range, ppm Reading, and ppm Range from that row.

3. Calculates uncertainty using the formula 

4. Calculates standard uncertainty using the formula

The standard uncertainty is the value Calibration Executive combines with 
the other standard uncertainties using the root-sum-square method to 
determine the combined standard uncertainty. The combined standard 
uncertainty is then multiplied by a coverage factor of 1.96, corresponding 
to a final expanded uncertainty with a 95% confidence level and a normal 
distribution.

Adding Uncertainty Components
If you want to add other uncertainty components, you can copy and modify 
an existing uncertainty file. For example, if you want to add an offset 
uncertainty component to all analog input tests, make a copy of the proper 
calibrator uncertainty file, rename it, and modify it by adding the offset to 
the µV offset column. 

If your DMM is operating outside of its normal temperature range and you 
want to account for the temperature difference, make a copy of the proper 
DMM uncertainty file and add the temperature coefficients to the absolute 
uncertainty specifications. When you run the Calibration Executive 
procedure, a dialog box prompts you for information on which calibrator 
and DMM you are using. If you want to use your modified uncertainty files 
and they are not in the list, click Browse and select your modified 
uncertainty files.

uncertainty ppm Reading Reading×
1,000,000

---------------------------------------------------------- ppm Range Range×
1,000,000

------------------------------------------------+=

Standard Uncertainty Uncertainty
1.96

----------------------------=
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit our extensive library of technical support resources available 
in English, Japanese, and Spanish at ni.com/support. These 
resources are available for most products at no cost to registered 
users and include software drivers and updates, a KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and 
application notes, instrument drivers, discussion forums, 
a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 
measurement and automation professionals by visiting 
ni.com/support. Our online system helps you define your 
question and connects you to the experts by phone, discussion 
forum, or email.

• Training—Visit ni.com/training for self-paced tutorials, videos, 
and interactive CDs. You also can register for instructor-led, hands-on 
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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Glossary

Symbol Prefix Value

µ micro 10– 6

M mega 106

A

adjust To correct the measurement error of a device by adjusting the calibration 
constants and storing the new calibration constants in the EEPROM. The 
host computer reads the calibration constants and the software uses them to 
compensate for errors in the data and to present calibrated data to the user.

asset A hardware device that you are calibrating. With Calibration Executive, 
you can calibrate assets such as E Series devices and SCXI modules.

C

calibration A set of operations that compares the values indicated by a measuring 
instrument or measuring system to the corresponding values realized by 
external standards. The result of a calibration can be used to determine the 
measurement error and can correct for it in the adjustment process.

combined standard 
uncertainty

The standard uncertainty of the result of a measurement when that result 
is obtained from the values of a number of other quantities, equal to the 
positive square root of a sum of terms, the terms being the variances or 
covariances of these other quantities weighted according to how the 
measurement result varies with changes in these quantities.

confidence The probability that a predicted result will occur.

confidence level Confidence, expressed either as a fraction (between 0 and 1) or a 
percentage.

coverage factor A numerical factor used as a multiplier of the standard uncertainty to obtain 
an expanded uncertainty.
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D

degrees of freedom Any of the unrestricted, statistically independent values of a sample that are 
used to determine a property of the sample.

DLL Dynamic-Link Library for Windows—libraries that link to a program and 
load at run time instead of being compiled into the program.

driver Software that controls specific hardware device such as a DAQ device or a 
GPIB interface board.

E

expanded uncertainty A quantity defining an interval about the result of a measurement that may 
be expected to encompass a large fraction of the distribution of values that 
could reasonably be attributed to the quantity being measured.

G

GPIB General Purpose Interface Bus—the standard bus used for controlling 
electronic instruments with a computer.

H

HTML Hyper Text Markup Language—a hypertext document format used on 
the Web.

I

IVI Interchangeable Virtual Instrumentation—an advanced architecture for 
instrument drivers that includes features such as simulation and state 
caching.

M

MB Megabytes of memory.

MHz Megahertz.
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N

NI-VISA The National Instruments implementation of the VISA standard—an 
interface-independent software that provides a unified programming 
interface for VXI, GPIB, and serial instruments.

R

resolution The smallest signal increment that can be detected by a measurement 
system. Resolution can be expressed in bits, proportions, digits, or percent 
of full scale.

S

SCXI Signal Conditioning eXtensions for Instrumentation—the National 
Instruments product line for conditioning low-level signals within an 
external chassis near sensors.

standard The instruments used in calibration such as calibrators, DMMs, and 
counters.

standard uncertainty The uncertainty of the result of a measurement expressed as a standard 
deviation.

structured query 
language (SQL)

An industry-standard language for retrieving, updating, and managing data. 

T

TestStand A test executive program that allows you to organize and execute sequences 
of reusable test modules. In Calibration Executive, TestStand manages the 
calibration procedures used to calibrate your asset.

Type A evaluation 
(of uncertainty)

A method of evaluation of uncertainty by the statistical analysis of a series 
of observations.

Type B evaluation 
(of uncertainty)

A method of evaluation of uncertainty by means other than the statistical 
analysis of a series of observations.
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U

uncertainty An estimate of the range of values about the measured value in which the 
accepted value is believed to lie.

uncertainty of 
measurement

A parameter, associated with the result of a measurement, that characterizes 
the dispersion of the values that could reasonably be attributed to the 
quantity being measured.

V

verify To compare the measured performance of a device to an external standard 
of known measurement uncertainty to confirm that the device meets or 
exceeds its specifications.
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F
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H
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I
installation directories, 1-4
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